If you are experiencing issues and would like to speak with our support team, please submit a help ticket.

General

The Buggiest Plug-in Award goes to...

The Buggiest Plug-in Award goes to...

... Titler Pro 3.

I cannot tell you how many times I have had issues with this program on many different machines, all of which are powerful editing machines capable of running every other program/plug-in/effect I've ever thrown at them.  All with the exception of Titler Pro 3.

Here is one of my favorites that I'm dealing with now:

 

 

Today, after be able to edit text via Titler Pro just fine (I was getting suspicious because of this),  I go to open a text layer to edit and it freezes up to a white shell and black frame.  This has happened before.  Staff at Newbluefx said to remove a .dll, that did not work.  This was followed by "Log out and log back into NewBlue Application Manager".  Nothing came from that, either.  

 

I had to restore my computer to an earlier time to fix Titler Pro.   That worked until today.   Now, I refuse to roll back my machine once again because this error decided to randomly rear its ugly head. I've since uninstalled, reinstalled, cleared registry, removed temp files, tried to narrow down the error to anything other than "Apphang",  to basically no success.  It still breaks upon execution.Sadly, many of my projects use this text program, and now I'll be set back on client deadlines thanks to this madness.  By the grace of the film gods, I hope someone comes out with a better, more intuitive plugin/software that WORKS so I can get out of this NewBlueFX hell.

Have a great day.